Changeset 867

Show
Ignore:
Timestamp:
05/30/06 18:05:29
Author:
miyagawa
Message:

Fixed XML::Liberal globally_override. Fixes #265

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/plagger/lib/Plagger/Plugin/Aggregator/Simple.pm

    r866 r867  
    1414$XML::Feed::RSS::PREFERRED_PARSER = first { $_->require } qw( XML::RSS::Liberal XML::RSS::LibXML XML::RSS ); 
    1515 
    16 #eval { require XML::Liberal }; 
    17 #if (!$@ && XML::Liberal->can('globally_override')) { 
    18 #    XML::Liberal->globally_override('LibXML'); 
    19 #
     16eval { require XML::Liberal }; 
     17if (!$@ && $XML::Liberal::VERSION >= 0.10) { 
     18    XML::Liberal->globally_override('LibXML'); 
     19
    2020 
    2121sub register { 
  • trunk/plagger/lib/Plagger/Plugin/Subscription/Bloglines.pm

    r835 r867  
    121121 
    122122    if ($@) { 
    123         $context->log(warn => "Bloglines Sync API returned bad XML. fallbacks to loop mode"); 
     123        $context->log(warn => "Bloglines Sync API returned bad XML. fallbacks to loop mode: $@"); 
    124124        my @feeds = $self->{bloglines}->listsubs()->feeds; 
    125125        for my $feed (@feeds) {