Changeset 831

Show
Ignore:
Timestamp:
05/26/06 17:21:32
Author:
miyagawa
Message:

globally override LibXML if possible

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/plagger/lib/Plagger/Plugin/Aggregator/Simple.pm

    r827 r831  
    1313 
    1414$XML::Feed::RSS::PREFERRED_PARSER = first { $_->require } qw( XML::RSS::Liberal XML::RSS::LibXML XML::RSS ); 
     15 
     16eval { require XML::Liberal }; 
     17if (!$@ && XML::Liberal->can('globally_override')) { 
     18    XML::Liberal->globally_override('LibXML'); 
     19} 
    1520 
    1621sub register {