Changeset 553

Show
Ignore:
Timestamp:
04/06/06 20:00:24
Author:
miyagawa
Message:

UNIVERSQL::require stuff. backward compatible to version 0.03 but recommends 0.10

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/plagger/Makefile.PL

    r546 r553  
    66requires('Class::Accessor::Fast'); 
    77requires('File::Find::Rule'); 
    8 requires('UNIVERSAL::require'); 
     8requires('UNIVERSAL::require' => 0.10); 
    99requires('Template'); 
    1010requires('Template::Provider::Encoding' => 0.04); 
  • trunk/plagger/lib/Plagger/Plugin/CustomFeed/Frepa.pm

    r542 r553  
    4646    for my $plugin (@$feed_type) { 
    4747        my $plugin = (ref $self || $self) . "::$plugin"; 
    48         $plugin->use or $context->error($@); 
     48        $plugin->require or $context->error($@); 
    4949        $self->aggregate_by_plugin($context, $plugin, $args); 
    5050    }