Changeset 345

Show
Ignore:
Timestamp:
03/06/06 16:55:52
Author:
miyagawa
Message:

use XML::RSS::Liberal if installed. Fixes #109

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/plagger/Makefile.PL

    r342 r345  
    4343        recommends('XML::Atom'), 
    4444        recommends('XML::RSS::LibXML', 0.18), 
     45        recommends('XML::RSS::Liberal'), 
    4546    ], 
    4647    'Publish::Gmail' => [ 
  • trunk/plagger/lib/Plagger/Plugin/Aggregator/Simple.pm

    r344 r345  
    44 
    55use Plagger::UserAgent; 
     6use List::Util qw(first); 
     7use UNIVERSAL::require; 
    68use URI; 
    79use XML::Feed; 
    810use XML::Feed::RSS; 
    911 
    10 $XML::Feed::RSS::PREFERRED_PARSER = 'XML::RSS::LibXML'
     12$XML::Feed::RSS::PREFERRED_PARSER = first { $_->require } qw( XML::RSS::Liberal XML::RSS::LibXML XML::RSS )
    1113 
    1214sub register {